Jump to content

  • Log in with Facebook Log in with Twitter Log in with Windows Live Log In with Google      Sign In   
  • Create Account
  • facebook
  • googleplus
  • twitter

Photo
- - - - -

không vào được máy khác trong mạng lan


  • Please log in to reply
16 replies to this topic

#1 nmtonline

nmtonline

    Junior Member

  • Member
  • Pip
  • 4 posts

Posted 24 February 2007 - 09:54 AM

Các bác ơi, giúp em với. Nhà em có 3 máy(A, B, C), kết nối internet thông qua một switch. Kết nối internet thì không có vấn đề gì, nhưng mà kết nối giữa các máy thì lại chỉ máy A vào được máy B, còn lại các máy khác với nhau không thể vào được gì cả.
Em đã tắt firewall của Windows cũng như hãng thứ 3, bật user guest lên rồi, chỉnh cho workgroup lại với nhau nhưng mà vẫn không vào được, nó xuất hiện lỗi thế này: \\dell-e1505 is not accessible. You might not have permitssion to use this network resource. Contact the administrator of this server to find out if you have access permitssions. ---Logon failure: the user has not been granted the requested logon type at this computer.
Các bác giúp em với, em tìm mấy ngày nay mà không ra phương pháp giải quyết.

#2 PETER

PETER

    Super Administrator

  • Admin
  • 3,057 posts

Posted 24 February 2007 - 11:25 AM

Theo như bạn nói:
Chỉ máy A vào được máy B => Máy C không vào được máy B => Kiểm tra lại Network Connection ở máy C. Chú ý cấu hình IP ở từng máy và điều kiện là các máy phải có chung 1 Workgroup.
- Về cấu hình IP, máy A, B, C mà bạn nói chạy trong 2 mạng là LAN và Internet. Nếu chỉ kết nối với Internet thì bạn không cần phải thiết lập cấu hình IP mà chỉ cần để chức năng cung cấp IP tự động của ISP dựa vào DHCP Server. Tuy nhiên máy A, B, C của bạn còn phải chạy trong mạng LAN nên cần phải cấu hình IP cho từng máy sao cho phù hợp để phân biệt địa chỉ của từng máy trong mạng LAN đó.
- Trở lại trường hợp ban đầu, Máy A connect vào được máy B, nếu không có thay đổi nào về Network Connection và Security ở máy A & B thì chắc chắn máy B sẽ truy cập được vào máy A. Như vậy nếu ở trường hợp của bạn máy B không connect vào được máy A thì bạn nên kiểm tra lại phần security ở máy A và tương tự ở máy C.
- Bạn vào Run gõ services.mscsecpol.msc /s để xem lại các trạng thái của Network Connection và Security Setting sau đó điều chỉnh cho phù hợp.

#3 nmtonline

nmtonline

    Junior Member

  • Member
  • Pip
  • 4 posts

Posted 24 February 2007 - 01:55 PM

Cám ơn bác, em đã test thử tất cả trước khi post.
Kết nối Internet bình thưởng, các cáp đều ok, workgroup cùng chung, DHCP tự động (vì adsl), đã bật user guest, các user đều có permitssion trong Admin groups, đã tắt firewall, kiểm tra tình trạng kết nối... nói chung là thỏa tất các điều kiện của bác, nhưng mà em vẫn không vào được mới cay. Bác nào giúp em với.

#4 PETER

PETER

    Super Administrator

  • Admin
  • 3,057 posts

Posted 24 February 2007 - 02:07 PM

Nếu mà ngồi đoán bệnh thì căng thật, chờ có ý kiến khắc. Mà bạn ở đâu thế, PETER đang ở P.1, Q.8, nếu như gần thì PETER ghé qua xem nó thế nào mà ngộ vậy :-?

#5 PETER

PETER

    Super Administrator

  • Admin
  • 3,057 posts

Posted 24 February 2007 - 05:42 PM

DHCP Server của ISP, vì ISP cung cấp IP (ảo) cho các máy để phân biệt các máy trên mạng Internet. Còn trong mạng LAN các máy con bắt buộc phải có IP riêng để phân biệt từng máy trong mạng LAN đó.

VD:
IP - LAN: 10.0.0.7 (phải thiết lập).
IP - Internet: 203.162.2.2 (do ISP cung cấp dựa vào DHCP Sever ở ISP).

#6 longbottom

longbottom

    Spam Happy

  • Super Moderator
  • 278 posts

Posted 25 February 2007 - 05:33 PM

Bạn nói không rõ lắm. 3 máy tính đó xài WinXp Pro or Home edition
Nếu bạn xài WinXp Pro thì bạn vô coi lại Local Security Polices.
- Phần :User right Asignment
Xem policy Acess this computer from network xem có everyone trong đó ko,
nếu ko thì add vô
Xem policy Deny access this computer from network, xem có Guest trong đó ko, nếu có thì remove đi
-Phần :Security Option:
Tìm đến policy Network access:Sharing and security model for local account
Chọn Guest only nếu muốn ko phải chứng thực
Chọn Classic nếu muốn chứng thực khi truy cập resource
Vậy là xong

Nếu bạn xài WinXp home Edition : thì cũng phải chỉnh lại Local Security nhưng mặc định Win home lại ko có GUI tool giống WinXp Pro nên bạn phải down tool về tại:
_http://go.microsoft.com/fwlink/?LinkId=4544

Sau khi down về, bạn install vô, sau đó vào Start, All Programs, Windows Resource Kit Tools, Command Shell
Nhập vào các lệnh:(gõ đúng bên dưới, phân biệt hoa,thường)
net user guest /active:yes
ntrights +r SeNetworkLogonRight -u Guest
ntrights -r SeDenyNetworkLogonRight -u Guest

Câu lệnh dầu tiên enable user Guest
2 câu lệnh tiếp theo để thay đổi cho phép user Guest truy cập network
Bạn cũng có thể áp dụng đối với các user khác ,ko nhất thiết là guest
Vậy là hoàn tất.
Have fun!!^^!!

#7 free_life_79

free_life_79

    Advanced Member

  • Member
  • PipPipPip
  • 99 posts

Posted 27 February 2007 - 07:11 PM

ôi , mình cũng bị y chang như thế , chỗ mình có 6 máy , thì chỉ có 1 máy là nó truy cập được vào tất cả các máy lấy dữ liệu , cỏn tất cả những máy khác lại không thể truy cập vào nó để lấy dữ liệu mặc dù vẫn nhìn tháy nó , và mọi điều kiện cho nó đều thỏa mãn , không hiểu tại sao nữa , bác nào biết cách trị chỉ mình với
Thanks

#8 lt63

lt63

    Spam Happy

  • Member
  • PipPipPipPip
  • 313 posts

Posted 27 February 2007 - 07:47 PM

Nếu các diều kiện IP trong Lan đã thỏa (cùng subnet )<= cái này hình như Ok vì máy A vào được máy B, mà máy B vào ko được máy B
bạn thử như thế này
Vào Star=> secpol.msc rồi chọn như hình
Posted Image

Nhìn sang bên phải

dòng 2 Enable
dòng 3 disable
Kéo xuống vào chọn như hình

Posted Image

rồi vào start=>Run gõ gpupdate /force

Ok giờ thử login lại

chúc thành công

#9 free_life_79

free_life_79

    Advanced Member

  • Member
  • PipPipPip
  • 99 posts

Posted 28 February 2007 - 03:54 PM

vẫn không được bác ơi , nó vẫn hiện cái thông báo thế này

Posted Image

#10 lt63

lt63

    Spam Happy

  • Member
  • PipPipPipPip
  • 313 posts

Posted 28 February 2007 - 04:04 PM

động tác trên làm ở máy Minhnhi nha và bảo đảm Guest bật,
bạn có thể chụp hình ở máy Minhnhi xem đúng như trên chưa

#11 free_life_79

free_life_79

    Advanced Member

  • Member
  • PipPipPip
  • 99 posts

Posted 28 February 2007 - 04:13 PM

máy đó hiện đang chơi Game , chờ nó rảnh em chụp cái hình post lên cho bác coi giúp

#12 canthomenyeu

canthomenyeu

    Junior Member

  • Member
  • Pip
  • 1 posts

Posted 24 March 2007 - 08:11 PM

Bạn thử đặt Pasword cho mỗi máy xem sao. Chúc bạn thành công.

#13 hoian

hoian

    Tiếu Ngạo Giang Hồ

  • Member
  • PipPipPipPip
  • 429 posts

Posted 06 April 2007 - 01:57 PM

theo như hình trên thì hình như chỉ như lão pt nói là do có phần security trong máy minhnhi
nếu như nmtonline bảo kiểm tra lại tất cả đều okie:
Kết nối Internet bình thưởng, các cáp đều ok, workgroup cùng chung, DHCP tự động (vì adsl), đã bật user guest, các user đều có permitssion trong Admin groups, đã tắt firewall, kiểm tra tình trạng kết nối... nói chung là thỏa tất các điều kiện của bác, nhưng mà em vẫn không vào được mới cay. Bác nào giúp em với.
thì hơi lạ đời!
ngoài những điều trên hình như ko còn điều gì khiến ko thể truy cập vào máy minhnhi!
có thể ông kiểm tra chưa ổn :D quan trọng là công đoạn kiểm tra
rãnh rỗi nếu ông vẫn chưa làm được thì làm từng bước một và printscreen lại đưa lên anh em cùng tham khảo chuyện lạ việt nam với?

#14 nguyenhung_it84

nguyenhung_it84

    Junior Member

  • Member
  • Pip
  • 16 posts

Posted 08 May 2007 - 10:04 AM

Máy ở Cty mình cũng vậy, lúc trước để File System là FAT 32 Thì các máy có thể truy cập dc với nhau, từ khi mình chuyển qua NTFS thì các máy vẫn nhìn thấy nhau nhưng ko truy cập dc dữ liệu của nhau dc. ip mình để như cũ, ko thay đổi gì cả.

#15 ToanNguyen

ToanNguyen

    Chém Gió

  • History
  • 771 posts

Posted 09 May 2007 - 12:15 AM

Tại vì NTFS nó bảo mật mạnh hơn, nên hạn chế tùm lum cả.
Mình phải gõ đúng tên và pass trên máy kia, thì mới vào được lận.

Edited by ToanNguyen, 09 May 2007 - 12:15 AM.


#16 ToanNguyen

ToanNguyen

    Chém Gió

  • History
  • 771 posts

Posted 09 May 2007 - 12:51 PM

Bạn làm như bạn longbottom:

bạn vô coi lại Local Security Polices.
- Phần :User right Asignment
Xem policy Acess this computer from network xem có everyone trong đó ko,
nếu ko thì add vô
Xem policy Deny access this computer from network, xem có Guest trong đó ko, nếu có thì remove đi
-Phần :Security Option:
Tìm đến policy Network access:Sharing and security model for local account
Chọn Guest only nếu muốn ko phải chứng thực
Chọn Classic nếu muốn chứng thực khi truy cập resource
Vậy là xong


rùi làm thêm các bước của lt63 nữa. (mà hình đâu hết rùi, sao không cập nhật lại đi?)

Tiếp theo, nếu bạn nào dùng NTFS thì nhớ set security cho cái thư mục muốn share là Everyone --> read thì mình nghĩ là được đấy.

Edited by ToanNguyen, 09 May 2007 - 12:56 PM.


#17 nguyenhung_it84

nguyenhung_it84

    Junior Member

  • Member
  • Pip
  • 16 posts

Posted 09 May 2007 - 01:15 PM

Giờ mình có thể chuyển đổi lại từ NTFS qua FAT 32 đuợc ko, mình đã thử convert trong cmd rùi nhưng ko dc. Có soft nào có thể làm dc ko mấy bạn?





Similar Topics Collapse

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users